+ Reply to Thread
Results 1 to 3 of 3
  1. #1
    Junior Member

    D600 lcd screen issue, argh

    hello all.
    sorry for my first post to be a problem post but i dont know where else to ask such a question.

    My father has a d600, that i purchased for him a few years ago, the camera has had very very light use, probably less than 5000 shots.
    yesterday he went to use it and the lcd is....well. doing something odd. Basically a bunch of coloured vertical lines. no images, no menu, nothing. the top lcd works fine, and the shutter etc works as it should, unfortunately, its not recording every image to the sd cards. it only does every few shots. so....im leaning towards possibly a motherboard (pcb?) issue? has anyone experienced anything similar with their d600 cameras?
    screens i have replaced before, did some reading on doing the d600, difficult, but doable. but if its the pcb.... then i have no chance haha.
    anyway, just putting the feelers out there and checking if its worth the repair or not, thats all


    › See More: D600 lcd screen issue, argh



  2. #2
    Senior Member
    Bikerbrent's Avatar

    Re: D600 lcd screen issue, argh

    Welcome aboard. Enjoy the ride.

    Sorry, can't help you with your D600 issue.
    Brent Harritt: Poway, CA: D7200, D200, D70, F100: Tokina 12-24mm, Nikon 18-200mm, Sigma 150-600mm, Nikon 18-70mm, Tokina 28-70mm f2.6-2.8, Nikon 50 f1.8, Nikon 80-200mm f2.8, Tokina 100mm f2.8 Macro

  3. #3
    Staff
    Challenge Team
    Moderator
    RocketCowboy's Avatar

    Re: D600 lcd screen issue, argh

    Howdy and welcome to Nikonites!

    The problem you're describing does not sound common, and unfortunately, I think you are on the right track with troubleshooting. If the camera is not recording each shutter activation to the SD card, then it sounds like the problem is more than just with the display.

    I would test with another lens, to rule out an issue with lens electronics, contacts, etc, but it sounds like you'll want to get this camera checked out by Nikon.


    Sent from my iPhone using Tapatalk





Quick Reply Quick Reply

If you are already a member, please login above before posting.

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •