D7000 Focus Problem


Senior Member
I bought a used Nikon D7000 body from an online source. It has a problem.

The AF does not work properly. When the shutter didn't work, the AF needed to be shut off on both the lens and camera body and the focus done manually. The shutter then worked as long as the image was in focus. When AF is turned off on the lens and the image is put out of focus, the shutter doesn't work. It resumes working when the lens is manually brought back into focus.

The Auto Focus and the whole camera does work when the AE-/AF-L autoexposure lock is used to prefocus before the shutter is pressed. The camera takes a while going back and forth until it finds a focus point. The shutter is inoperable otherwise.

Focus is fuzzy in point and shoot mode

I tried both Auto AF A, and AF S. I also tried AF-S with a single focus point with no improvement. I reset the body to factory defaults with no change in symptoms. I do not use live view.

This was tested with 3 different AF-S Nikkor lenses. These lenses auto focus properly on my other Nikons. They do not hunt for the focus point when used on my D70s.

D7000 Firmware info is; A 1.04 B1.05 L 1.002 Shutter count is 40480.

The camera was purchased from a source source that is thought of as being reputable and will not yet take it back. They believe that I do not know how to set the camera. They may be right.

I've been using my beloved D70s for a very long time. I wanted a body with a higher resolution than the D70s for a time lapse project.
The D7000 promised me a higher resolution body for about $200. I assumed the D7000 could be used as if it was just a D70s with higher resolution. I also assumed anything anyone needed to know about how to actually use the D7000 would be in the official Nikon D7000 manual.

Wrong on both counts!

The D7000 is now just a nice manual focus DSLR. Am I overlooking something? Is there a magic setting somewhere that will set everything right? If it cannot be returned, any ideas on a repair price range?

I prefer to keep the D7000 and make it work....within reason. I may be able to do this time lapse project in manual mode. But, still would like to have a fully functioning camera.

Interesting unrelated thing. The name of the previous owner was in the exif files.


Senior Member
I had a couple theories. But a factory reset would fix both of those.
Good luck, and stay on that vendor. The three I use all have a generous return policy and/or warranty.


Senior Member
Could be reading this wrong but it sounds like you have focus priority set on the shutter release, meening unless the camera is in focus it wont take a picture, you can change it to release priority but most of the time i dont see any point in that.

Fred Kingston

Senior Member
You need to read/understand and set the A1 and A2 Custom Menu options to "release"... The default is "Focus"
Last edited:


Senior Member
Hard to follow exactly what your problem is. Sounds like you are set up improperly for back button focus. But other things don't add up. Like if you put the lens in manual focus and the shutter still doesn't trip unless you get the camera in focus. That sounds not possible or something not working right. When the lens or body is switched to manual focus, the camera should not require focus to fire the shutter

A reset does not reset everything. The manual lists exactly what will be reset with a 2 button reset. If you go the shooting menu and also the custom menu, you will see a reset for each. That still won't get 'everything'. Let us know how it works after you reset the custom menu. That should get rid of any remaining back button focus settings.

To get rid of the previous owner, go to setup menu and look at the comment and copyright items and clear them out.