D700, USB cable to Linux laptop/desktop


Senior Member
My daughter has a D700.
I already had to replace the card slot board because she snapped a pin in the card slot putting the card in and out, so I told her to just use a USB cable to copy her photos and leave the memory card alone.
The USB cable works fine in Windows, but, I can't get it to show up as a drive on our Debian Linux laptop.
Has anyone else tried this and gotten it to work?


Senior Member
Challenge Team
This is probably not much help. I run Fedora and my D810 & D7100 auto-mount and show both cards. If it finds other devices like usb drive and card readers I would say you have auto-mount turned on. Maybe try turning the camera on before plugging the cable into the laptop. Is there possibly a program that is trying to mount the card.
I use a card reader and have for my cameras, to date no pin problems but only the SD card is ever removed from the 810.


Senior Member
I think that gtkam would probably work as well. The fundamental point seems to be that on a Linux system that ptp mode has to be used instead of mass storage mode. This won't work (as far as I know) "out of the box" because it doesn't just pop up as a drive, but instead needs software to be added to support downloading using ptp mode.