+ Reply to Thread
Results 1 to 8 of 8
  1. #1
    Junior Member

    D610 and SB600

    I own a D610 and recently I bought a SB600 which I command with a pair of Yongnuo YN622 TX/RX.
    I use the flash only for HSS but recently I could not make it work in TTL, apparently the flash works properly only in manual mode.
    I.e. Setting manual on the camera and flash the triggers fires, otherwise the triggers send the signal but the flash just won't fire.
    I wonder if this is normal, or is it due to the triggers or whatever.
    By the way I recently purchased two much simpler yongnuo triggers RF603 and they won't work in HSS, but that was not surprising, I guess.
    Thank you in advance for any help/suggestion


    › See More: D610 and SB600
    Last edited by rodocarda; 12-27-2017 at 01:35 PM.



  2. #2
    Staff
    Challenge Team
    Moderator
    RocketCowboy's Avatar

    Re: D610 and SB600

    Quote Originally Posted by rodocarda View Post
    I own a D610 and recently I bought a SB600 which I command with a pair of Yongnuo YN622 TX/RX.
    I use the flash only for HSS but recently I could not make it work in TTL, apparently the flash works properly only in manual mode.
    I.e. Setting manual on the camera and flash the triggers fires, otherwise the triggers send the signal but the flash just won't fire.
    I wonder if this is normal, or is it due to the triggers or whatever.
    By the way I recently purchased two much simpler yongnuo triggers RF603 and they won't work in HSS, but that was not surprising, I guess.
    Thank you in advance for any help/suggestion
    I haven't tried that specific flash setup, but I have noticed problems with my SB910s when paired up to the YN622. While the 622s seem to work find for ttl and hss with the YN568s, there's something about that remote that the SB910s just don't like ... and it might be the same thing your SB600 is complaining about.

  3. #3
    Staff
    Challenge Team
    Moderator
    RocketCowboy's Avatar

    Re: D610 and SB600

    Oh ... and welcome to Nikonites!!!

  4. #4
    Senior Member

    Re: D610 and SB600

    First off.. you don't need a 3rd part trigger to do what you're describing... The D610 will do those things with the SB600 directly using Nikon's CLS

    Have you tried that to ascertain that the camera and flash are working properly?

  5. #5
    Junior Member

    Re: D610 and SB600

    I guess you are right. In fact it seems to work properly in manual mode, but no way to make it work in TTL. Which is not a real disaster as I do not do weddings or events, I mostly shoot portraits so I usually have time to adjust the lighting of the scene.

  6. #6
    Junior Member

    Re: D610 and SB600

    Thanks., I have been a Nikon user for 41 years now, so I guess i belong to the family :-D

  7. #7
    Junior Member

    Re: D610 and SB600

    Yes it works as you said, but there are times when a trigger is required, for instance when the visibility is poor between the two flashes, or when the remote flash is embedded in a sofbox or a diffuser, sometimes cls won't work.

  8. #8
    Senior Member

    Re: D610 and SB600

    Yes... A trigger would be needed for those circumstances... I was only suggesting CLS as a test to be sure the camera and light are working correctly... before adding the trigger... The trigger won't ever do anything the camera and light won't do by themselves... IOW, test the two while they're 5' apart and unobstructed... if that fails, then the trigger isn't going to work either... as you move them farther apart, and/or the light/obstruction conditions change, then add the trigger...





Quick Reply Quick Reply

If you are already a member, please login above before posting.

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •